IP Command no longer works

Jan 23, 2013 at 6:51 AM
Edited Jan 24, 2013 at 1:55 AM

2013-01-23: No crash or anything, just no response at all.  Other commands are working fine (ping, message etc) Looks like whatsmyip.com have changed their end.

log file says:

1/23/2013 7:16:13 AM    Status changed to 'Sending tweet-respond...' with tweet-message: internal IP Address : 10.0.1.250  external IP Adress: We have removed the .asp version of this script from our website. Please click here to learn about our new "Automation" services.
1/23/2013 7:16:13 AM    sending tweet failed!: Status is over 140 characters.

Workaround:  TweetMyPC custom command - Use a text browser to grab an alternative whatsmyip site + command line email program to email the result to myself.

Links win32: http://www.jikos.cz/~mikulas/links//download/binaries/win32/

mailsend: http://www.muquit.com/muquit/software/mailsend/mailsend.html#download

 

Example 2 line batchfile that sends an email from user "agmailaccount@gmail.com" to user "myemailaddress@mail.com" with file attachment "output.log" using gmail smtp server:

rem -----------------------------------------------------

links-0.98.exe -dump http://www.whatsmyip.info/ > output.log

mailsend1.16.exe -ssl -smtp smtp.gmail.com -port 465 -t myemailaddress@mail.com +cc +bc -f agmailaccount@gmail.com -sub "TweetMyPC output.log" -attach "output.log,text/plain,i" -M "Logfile attached" -v -auth-login -user agmailaccount@gmail.com -pass gmailpassword

rem -----------------------------------------------------

- then add the batchfile into TweetMyPC as a custom command.  I compiled it into and exe first (using a 2 line autoit script that just calls the above 2 lines) so my passwords would not be visible.

Also, this looks nicer if you don't mind some AutoIt scripting.  Scrapes the website and sends the email all from one script file compiled into an exe.  Requires some modification.

http://vnucleus.com/2012/02/using-autoit-scrape-website-via-ie-and-send-alerts/

Coordinator
Mar 19, 2013 at 5:17 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Mar 28, 2013 at 1:02 AM
fixed as of now with version 4.0.4. use the update feature in the help menu of TweetMyPC.

also fixed the screenshot command, the new twitter api 1.1 and the hidden window problem.